PDA

View Full Version : Compatibility TC patch 3.1 has been released....



NovaCatt
18-02-2011, 04:02 AM
Hiya Peeps, :wave:

For those who haven't noticed, ES has just released TC patch 3.1.... Linkie to details on ES (http://forum.egosoft.com/viewtopic.php?t=296699)

WARNING!! It is highly recommended that you rename your XTC files (cat/dat 13 & 14) plus any false patch files to one (1) number higher, as patch 3.1 also contains cat/dat 13 & if you install the patch without renaming your current cat/dat files it WILL overwrite XTC thereby ruining your game....

I know it contains cat/dat 13 as I have just installed it on my 'puter, having made sure I renamed all my cat/dat files from #13 (XTC main mod files) onwards as a precaution {IE: I renamed cat/dat #14 to become cat/dat #15 & cat/dat #13 to become #14}, after it finished installing I noticed it had added cat/dat 13 to the folder....
I'm glad I did rename the files as I had a suspicion it may have included #13 cat/dat, plus it's a good general rule of thumb to rename your files when install a new patch from ES.... ;)

Oh yes, before I forget, this would appear to be the last patch for TC going by what they say in the thread I linked above..... :cry:

Cheers & Thranx

Aragon Speed
18-02-2011, 05:54 AM
I would like to point out that XTC is designed to work with 3.0 and we do not yet know if 3.1 will cause any problems with changed files. So if you run 3.1 and find new oddities there isn't much we can do about it currently.

NovaCatt
18-02-2011, 08:57 AM
Hiya Peeps, :wave:

Addendum....
I will be dropping out & testing the new patch with XTC in the next few minutes... I ask that everyone hold off on installing 3.1 to XTC for the next few hrs until I've had a chance to report on any issues....

I will report any problems I find directly to AS, so he has a heads up on what may need to tweaked in XTC to make it compatible with 3.1.... (which means if I find any problems, AS is gonna get an inbox full of gibberish, as I try to explain what happened.... :p)

Cheers & Thranx

Aragon Speed
25-03-2011, 04:25 AM
I assume there are no problems that have been found yet NC?

Aragon Speed
25-03-2011, 05:45 AM
A quick 'n dirty guide for using XTC 1.1 with TC 3.1. Only do this if you know what you are doing with the files. ;)


1. Copy your scripts folder to the desktop.

2. Rename the XTC cat/dats to one number higher.

3. Install the TC 3.1 patch.

4. Copy your scripts folder back again.

New installs:

1. Install TC and patch to 3.1.

2. Create a new empty folder on you desktop.

3. Install XTC to the new folder.

4. Change the XTC cat/dat numbers so they are one number higher.

5. Copy all files to your main TC directory/folder.

Warning, both of these methods will break the XTC uninstaller as the files will not be named the same, or will not be in the same location, as they were when you installed them.

Aragon Speed
12-08-2012, 06:29 AM
Out of date. Unstuck.