PDA

View Full Version : Wonky Data Transport Mission



OOZ662
27-12-2012, 04:13 AM
Have been running XTC2.0 without any glitches for the past three days. Received a combat mission in Teladi space to transport a piece of data. Was attacked by Yaki as I neared the destination (nice touch with the text in the tutorial box, by the way). Killed them, docked, was paid. Undocked and flew a bit before receiving a follow-up mission to "salavage" a ship in a distant Paranid sector as part of my reward. Flew to the coordinates to find an unowned Valkyrie being guarded by a Pirate Buster Hauler. Being of very low combat rank, I figured that was about right. Killed the Buster and as I approached to claim the Valkyrie, something caught my eye just below the ship and I veered off thinking they might be playing the old SQUASH Mine trick ala LooManckstrat's Legacy. Upon closer inspection, it was actually what looked like a really big Space Fly, and could be pushed around with the nose of my ship (with accompanying squish) but couldn't be targeted or seemingly fired upon. I dumped a navsat on it so I could come check on it later to see if it was a Lifeform doing something. Finally, upon claiming the Valkyrie, the mission flagged completed and a highly damaged pilotless Mammoth spawned 1.79km away from me.

2Blackhawk
27-12-2012, 12:54 PM
so what is your point? you have posted in the tech forum here we have strikt posting rules.

OOZ662
27-12-2012, 01:03 PM
"Please post here if you [...] want to report bugs with the X-Tended - Terran Conflict modification."

Spawning a Mammoth, especially one without a pilot, means that something was looking to spawn a ship that doesn't exist in TShips. "Salavage" is a typo in the mission description. The Space Fly thing is suspiciously convenient being spawned on the exact same x and z coordinates as the Valkyrie and thus I wasn't sure if it was also something spawned by accident as well.

Dillpickle
28-12-2012, 01:14 PM
These are all bugs - or at least the spacefly in itself isn't a bug, as they're often used as place markers for creating objects at a set position, the bug with this one is that he wasn't being cleared away once finished with.

For future reference when reporting multiple bugs at once can you separate them into individual paragraphs, and especially with spelling mistakes notify it as a bug:

BUG: Spelling 'Salavage' should be 'Salvage' - if you hadn't mentioned it again in your second post I would have put it down to one of the many typos that are found on the internet, and an easy fix would have been missed.

zx9000
13-01-2013, 04:04 PM
I have seen the same thing: a unowned Mammoth spawned after claiming the ship of a "Salavage"-mission. The mammoth have no max-speed statistic and can't be claimed with the Salvage Claim Software. I have a clean install of TC 3.2 and XTC 2.0.

Dillpickle
25-01-2013, 10:21 AM
Fixed for next patch.

birdtable
02-03-2013, 05:22 PM
Hi .... Not sure if bugged doing Shanty start no mods of any kind, clean install ....whenever I do transport data mission get the location of salvage I always get mission failed when I leave sector,, give the salvaged ship shields or use a Pelican makes no difference........What am I doing wrong ....?