PDA

View Full Version : Almost all ships use "SMALL" shields???



billinauburn
05-01-2013, 10:56 PM
Did I set something up wrong? All of my ships up to this point use small shields, eg. m3, m4, m5, m6, tp, ts. So is this right?

Loriel
05-01-2013, 11:04 PM
That looks wrong.

I think maximum shield size is fairly universal for each class of ship, and as I recall it should go something like this:
M5 = tiny
M4 = small
M3, TS (most), TP = medium
M6, large TS = large

So M4 and upwards would be able to use small shields, but most of them would also be able to use larger ones.
M5 would not be able to use small shields.

Are your shield sizes based on descriptions form Encyclopedia/info from looking at ships/info from shipyards or from practical experience trying what shields will fit?

Loriel

billinauburn
05-01-2013, 11:30 PM
If I put a medium shield in a M6 it shows as no shields. My Katana shows, in the Statistic Centre-Detailed ship report, 6x Small Mil. Hard.

Fresh install, upgrade to 3.2, properly installed 2.0, Licks(sp) compilation w/ patch, repair laser.

Loriel
05-01-2013, 11:49 PM
Looks like a faulty installation, but I suspect the installation of Lucike's Scripts will mark the installation as faulty anyway - see the thread at http://www.thexuniverse.com/threads/23239-Compatibility-XTC-2-0-with-Lucikes-Script-Collection-for-X-Terran-Conflict

What I would suggest is to create a new clean install - i.e. X3 Terran Conflict, Upgraded to 3.2, then XTC 2.0, and nothing else - in a different directory (but keep the current one at least for now).

Then try starting the new installation, and check that it gives a green 2.0, and then try to continue the existing game, and see what happens - whether it creates any new problems, and whether it solves the existing shield problems.

Current reports don't indicate significant problems with the Luckie Script package, though you may need to patch it slightly to avoid certain conflicts, so my suspicion falls on the "repair laser" mod.

Loriel

MadMac
06-01-2013, 06:46 PM
Don't know if this help but it sounds familiar...
http://www.thexuniverse.com/threads/23156-Possible-Bug-Argon-Mammoth-Only-Allowed-1-Small-Shield-Emmitter?highlight=small+shield